This document provides information on how to fix your sudo rules if they are not being applied.
Scenario
Your sudo rules configured in EPM Linux are not being applied.
Cause
There are two possible causes for this problem:
- The user added to the sudo rule is not in the
gonixgroup. - The rules are not being applied in the
sudoersconfiguration file due to incorrect syntax.
Solutions
To remedy this problem, there are two alternatives depending on the cause.
Solution 1:
If the user that is trying to use the sudo rules are not in the gonix group, see the Requirements section in How to Manage Sudo Rules in EPM Linux and add the user to the group.
Solution 2:
To verify if the rules are being applied in the sudoers configuration file, see the following steps:
- In the command line, run the following command with a privileged user:
cat /etc/sudoers.d/senhasegura. - With the file opened, try to save it.
- If your rule syntax is incorrect, a message will be displayed informing you that you have an incorrect syntax at a specific line.
- To fix the syntax, follow the How to Manage Sudo Rules in EPM Linux guide.
- If your rule syntax is correct, you will be able to save the file successfully.
- If your rule syntax is incorrect, a message will be displayed informing you that you have an incorrect syntax at a specific line.
Conclusion
After following these steps, all the sudo rules must be applied correctly. If the issue persists, contact the Segura® Platform technical support for further assistance.